• Announcements

    • shedder101

      WE Have Moved To www.renaultkadjarforum.com   06/11/2018

      i invite all members to take a look at this our new home    https://renaultkadjarforum.com/   we are moving to a better side of the street    See you all There.   if your having trouble registering look for the activation email in your spam folder   Shedder101

Airbag Warning Light
1 1

8 posts in this topic

Yesterday was the first time I've driven with someone in the passenger seat. After a short distance, the airbag warning light appeared on the instrument panel - see the attached rather poor quality image . This intermittently  went off and then back on again for the entire 1 hour trip. This morning, with just me in the car, the warning light did not come on. I then  applied pressure to the passenger seat by just pushing on it, and the warning light came on again. I have the car booked in to replace a faulty passenger side courtesy/map reading light so will have this looked at also. I just wondered if anyone else had this problem or if its related to the "airbag" recall issue?.  

 

post-325-0-79424600-1463387153_thumb.jpg

Share this post


Link to post
Share on other sites

If it persists I would contact the dealer to discuss. Failing that, check the discussion on ODBII connectors and see if there is an alarm code being generated for a faulty sensor or airbag 

Share this post


Link to post
Share on other sites

The airbag switch is in the "ON" position - it is not something I would have touched anyway The manual suggests that there is a different symbol for when the airbag is deactivated and also the light with the "spanner" symbol would not be displayed, Therefore I believe it to be a genuine fault.  When I drive home later I will deactivate/re-activate the airbag switch to see if it has any effect.

Share this post


Link to post
Share on other sites

After deactivating/activating the airbag switch the warning lights have now stopped coming on. Also the passenger side  "seat-belt unfastened" warning light and "beep" are now activated which weren't working before.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

1 1