• Announcements

    • shedder101

      WE Have Moved To www.renaultkadjarforum.com   06/11/2018

      i invite all members to take a look at this our new home    https://renaultkadjarforum.com/   we are moving to a better side of the street    See you all There.   if your having trouble registering look for the activation email in your spam folder   Shedder101

Retractable towbar does not unretract
1 1

19 posts in this topic

Hi,

I fitted a genuine Renault rectractable towbar today on my Kadjar with a 13p wiring harness (also Renault genuine). All according the fitting instructions that came along with the towbar and wiring harness.

The problem I encountered is that the towbar does not unrectract when pulling the metal cable.  All electronics seem to be working fine.

Has someone had the same problem? Can someone advise whats wrong?

Thanks for your help.

Regards, Marco

Share this post


Link to post
Share on other sites

When you pull metal cable in trunk you just unlock towbar. Now yuo must kick it into position under bumper.

I have same installation as you and works perfect.

Share this post


Link to post
Share on other sites

I also have this fitted. If you pull it fast enough it swing fast enough to lock in position. If not - kick it to lock. Is it possible to have some secure locking for the mounting which must be removed prior normal working from the mounting onwards?

Share this post


Link to post
Share on other sites

It is still in the stowed position behind the bumber. When I pull the metal cable (to its end position) nothing happens. I don't know if it's also an electrical unlocking or just mechenical by the metal cable. I'm a little scared the cable will break when pulling harder. I also thought about a secure locking that needs to be removed first, but in the installation manual there is nothing about that. I was hoping someone in this forum has some experience with fitting the retractable towbar, and maybe knows if there is a secure locking. Apreciate your help!

Share this post


Link to post
Share on other sites

I can't help. Mine was fitted at the dealer's garage couple of months after I bought it. (Took them that much, cause first time was the wrong set (and wrong price - instead of 500 euro it appeared to be 1200), then forgot some plates and the third time wrong wireing. At least they made me a big discount for the delay)

Share this post


Link to post
Share on other sites

Mine was also fitted ad delivery at the dealer's garage... for 750EUR (complete tow, wireing and labour).

But connection module was already replaced twice. First time due to tehnical note in 2016 and second time this year due to electronic fault.

Share this post


Link to post
Share on other sites

Fitted mine myself there is no locking position.just pull cable and it should come down. The housing the pull switch is located in can be unscrewed  two screws there is an outer locating clip that holds the outer sleeve it could have slipped so the cable is not detaching the locking mechanism.  Is this the 1st time you have tried to unlock it , when I fitted mine the cable  has to run a specific route so I wounder if the cable is twisted around part or the two bar .. I hope it helps do you have the fitting instructions  I will post son pics of the instructions if you want..

Share this post


Link to post
Share on other sites

Hi Roxy 1234,

I tried unlocking before mounting the towbar. It did not work then. At that point I thougt the wiring harness should also be fitted and powered (12V with the red cable) because there is also electronics on the towbar. As I mentioned all car electronics are working fine and there is 12 volts on the red cable. I needed to put the 20amp fuse in the fusebox first on the "dealer opt" position. So far so good. But the towbar still did not unlock. I checked the cable route, that also seems to be fine (not twisted). The cable moves freely for about 1 - 1­,5 inches. I used a little force at the and but nothing happens, other than getting really frustrated that I can't find the reason for the problem.

The part you mentioned about the pull switch housing and the outer locating clip isn't clear to me. Some pics of the instructions would really help me understand.

Thanks for your help and advice.

 

 

Share this post


Link to post
Share on other sites

Hi,

I still haven't found a solution for my problem. I have been looking a bit further and am wondering what the function is of the small red block underneath a blue rubber cap. It is located on the housing the pull cable goes in to.

Does someone know??

Renault Kadjar retractable tobar.jpg

Renault Kadjar retractable tobar blue rubber cap.jpg

small red plastic block.jpg

Share this post


Link to post
Share on other sites

I have to say when I fitted mine I did not remove that cap it worked out of the box. I did pull the cable before I clipped the cable so the tow bar was retracted  on the garage floor plz see pics attached. 

E226481C-C0A2-4EC6-9C34-7A31774F1281.jpeg

69AF15E7-1EDD-4349-9EAD-D40EFB3B111A.jpeg

Share this post


Link to post
Share on other sites

Have you fitted the cable housing bracket .... I would pull the cable out and try and pull the cable using a pair of grips. This is only because you may have twisted the cable when routing it through the bodywork...

Share this post


Link to post
Share on other sites

Done all that. But unfortunately didn't help. Sent an e-mail to Bosal in Germany yesterday with  a request for help. I did not receive a reply yet....

Share this post


Link to post
Share on other sites
37 minutes ago, Marco said:

Done all that. But unfortunately didn't help. Sent an e-mail to Bosal in Germany yesterday with  a request for help. I did not receive a reply yet....

I hope you get it sorted sorry I could not be of help ...

Share this post


Link to post
Share on other sites

Thanks.

One question though. When you tried yours on the garage floor was it without 12 volt supply? Only mechanical with the pull cable? After further research I am sure now that the pull cable functions all the way to the turningpoint of the towball. But it still won't unluck. I there is no electrics needed to unlock I maybe need to send it back to the supplier for repair or replacement.

Share this post


Link to post
Share on other sites
8 hours ago, Marco said:

Thanks.

One question though. When you tried yours on the garage floor was it without 12 volt supply? Only mechanical with the pull cable? After further research I am sure now that the pull cable functions all the way to the turningpoint of the towball. But it still won't unluck. I there is no electrics needed to unlock I maybe need to send it back to the supplier for repair or replacement.

It was not connected to a 12v just tried it to see how it worked sounds like something has has jammed.. I hope you get it sorted 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

1 1