• Announcements

    • shedder101

      WE Have Moved To www.renaultkadjarforum.com   06/11/2018

      i invite all members to take a look at this our new home    https://renaultkadjarforum.com/   we are moving to a better side of the street    See you all There.   if your having trouble registering look for the activation email in your spam folder   Shedder101

R link 2 and Sony xperia xz premium.
0

2 posts in this topic

Hi everyone. 

Would love some advice Please? 

Got a sexy shiny new Sony xperia xz premium, but when I connect it via Bluetooth to my kadjar it connects to multimedia but not by phone. If i look at the handset it says it is connected for multimedia, call audio and contacts, but touch the r link 2 head unit phone symbol and it just tries to connect to the xperia again. 

I had a Samsung note 4 that worked perfectly with the r link, and deleted that prior to adding the xperia. 

Extremely frustrating.  

Thanks in advance

Oh and have tried android auto with xperia but that's a no as well because I got my kadjar in April 😣

Edited by Jojo
Duplicated word in title

Share this post


Link to post
Share on other sites

Hello,

I have 3 Xperia : XZ, XZ Premium and the new one XZ1, and all works just fine with R-link2. With XZ i had a problem in April, because the firmware of r-link 2 was outdated and have some problem with android 7.  I go to dealer and upgrade the firmware and from then until now, bluetooth works fine. Check your R-link 2 firmware version. Now on XZ1 i have Android 8.0 (Oreo) and works fine.

Rlink 2 Software version: 2.2.17.803.

Boot Release: 4992

If you have the same software version, try to factory reset both: XZ premium and R-link 2 and try again to pair it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

0