• Announcements

    • shedder101

      WE Have Moved To www.renaultkadjarforum.com   06/11/2018

      i invite all members to take a look at this our new home    https://renaultkadjarforum.com/   we are moving to a better side of the street    See you all There.   if your having trouble registering look for the activation email in your spam folder   Shedder101

Noise from power steering
2 2

17 posts in this topic

Got exactly the same thing on my 1 year old S Nav.  The noise started about a week ago after the car had its first service.  I'm going to visit the dealership as soon as possible.  It's quite an alarming noise really.

Share this post


Link to post
Share on other sites

Just back from a very fast dealership, who have diagnosed that it's a steering shaft support strut ?  It needs replacing.  They have ordered the parts and should have it fixed in days, meanwhile, its safe to drive.  Hope that helps.

Share this post


Link to post
Share on other sites

Zen, 1.6dCi, 2WD. 16000km, 10 month old.
Unfortunately, I also have this sound.
It starts 20 days ago, When car is still or at low speed, and I turn power-steering left.
It starts like "whirr" sound.
Now it sounds like a cat meowing. Sometimes it is loud, sometimes is weak.

Share this post


Link to post
Share on other sites

Yes I Got exactly the same thing on my 6 month old Kadjar Signature S Nav. the dealership told me the same thing but it only took them 2 min's to fix it as it was only the heat shield catching on the power steering

Share this post


Link to post
Share on other sites

I've got a 6 month old Sig Nav and recently had similar problem with grinding noise coming from steering wheel . It was intermittent and every time I took it in to Renault they couldn't hear it until one day when it was quite constant and it turned out to be the Rotor Switch behind the steering wheel . For some strange reason it's not a part that Renault produce so had to wait 5 days for them to get one and just had it fitted yesterday . Seems to have solved it . Hope that may help .

Share this post


Link to post
Share on other sites
On 2/8/2017 at 6:03 PM, DAVE MORSE said:

Yes I Got exactly the same thing on my 6 month old Kadjar Signature S Nav. the dealership told me the same thing but it only took them 2 min's to fix it as it was only the heat shield catching on the power steering

I have a similar issue.

From reading all the above, there seems to be a few different opinions as to what is causing the issue.

Steering shaft support strut, Heat Shield & Rotor Switch...

If the Heat Shield fixes the issue that would be preferable as it seems like the easiest fix. 

Is it still running away without noise?

I'm going in for service in the next week or so anyway, so i'll see what they come up with, but it's always good to have a bit of knowledge on these things....

 

Thanks,

Share this post


Link to post
Share on other sites
On 09/02/2017 at 2:32 PM, EbbeK said:

Same problem in my Kadjar 1.6 Cdi Zen from sept. 2015.  Awaiting sparepart to arrive from France.

Recorded the noice :

 

Hi, this is the exact noise my kadjar is making. Renault say I’ve to wait till it gets worse because it’s intermittent they can’t find it whenever I take it in. Taken in twice now, did you ever find out what your problem was? My dealership is due another visit, I’m getting impatient now, I want it fixed.

Share this post


Link to post
Share on other sites

The sound you recorded Pumpkin is exactly what I had. They found a faulty steering joint, replaced it and it was fine. Recently, it has happened again, but has gone away in th roast few days. I believe other reasons have been given for this noise, including a heat shield rubbing on the steering shaft. I’ve decided to ignore the noise at the moment, I will replace mine in January 2019, it probably won’t be a Kadjar that replaces it.

Share this post


Link to post
Share on other sites

Hi, thanks for the quick replies. I’m going to ring Renault again tomorrow. Last time it was in they blamed it on a gromit on the steering rack, so they lubricated it. I returned the next day with the noise still there and they said it was normal for EPAS to make that noise. I think I need to be more pushy his time round, getting ridiculous now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

2 2