• Announcements

    • shedder101

      WE Have Moved To www.renaultkadjarforum.com   06/11/2018

      i invite all members to take a look at this our new home    https://renaultkadjarforum.com/   we are moving to a better side of the street    See you all There.   if your having trouble registering look for the activation email in your spam folder   Shedder101

toejam23

Members
  • Content count

    17
  • Joined

  • Last visited

  1. 🤡🤡🤡 Name and shame time me thinks! 🤔 Sent from my SM-G935F using Tapatalk
  2. Air / heating system

    Mine does exactly the same. Whatever the last heat setting was on it will occasionally blow that temp out. Doesn't happen all the time, just randomly. Must just one of those "funny" Renault quirks! [emoji36][emoji36][emoji36] Sent from my SM-G935F using Tapatalk
  3. New here looking for Clio info

    Hi Paul, you want to do what with this car??? [emoji50][emoji23] This isn't that kind if forum I'm afraid. Sent from my SM-G935F using Tapatalk
  4. Original orange ones look awful under bright white leds when turning. Sent from my SM-G935F using Tapatalk
  5. Hey all

    Hi to all, Had the car for a couple of months now and loving it so far. Been luurking around the forum for a while too getting some good ideas and help and hope to help where i can. Car is a Sig Nav 1.5 Nick
  6. Hey all, Great write up. I ordered the same ones as your link and installed the first one on nearside (not the easiest, cut and bruised arm ) but it seems to have a very slight flicker when i switched the fogs on to check them. Anyone else have the same issue? Nick